Windows 2003 terminal server not issuing licenses


















Event ID is typically seen with when no license server can be contacted. The most common root cause for these event log entries is a failure to discover the license server.

License Servers must be discovered by Terminal Servers. Once located, a digital certificate exchange takes place so the terminal server can check CALs allocated to clients by the license server.

Discoverability is critical. When launched on a terminal server, this utility will display any license servers that are discovered, and list the type of license server Domain or Enterprise , as seen in Figure 1.

If no servers are displayed in LSVIEW, either the license servers are offline, or they cannot be discovered by this terminal server. License Servers are discovered a few different ways, depending on which mode the license server was installed. When an Enterprise License Server is installed, an Active Directory registration is created under the configuration container in the site to which the license server host belongs.

When the license server is installed, the administrator performing the installation must have the appropriate rights in AD to create the object. If not, the registration may not complete and the terminal server may not be able to discover the license server. Under the properties of this object, look for the siteServers attribute and check the values. This identifies the registered license server s for the Active Directory site. For the full details on license server discovery, check out my articles on the subject, also available on this site.

To summarize, follow these suggestions to ensure your license servers are easily discovered:. Finally, some additional things to check here are basic network and RPC connectivity, and be sure the license server is online and the license service is started.

Windows Server introduced the ability to control which terminal servers can access a particular license server through the use of a new group policy setting — License Server Security Group. If you are leveraging this policy, be sure that the terminal server in question has been added to the policy so it can access the licensing services.

Also check to see if the terminal server in question is the license server. In the policy list, right-click Use the specified Remote Desktop license servers , and then select Properties. Select Enabled , and then enter the name of the license server under License servers to use. If you have more than one license server, use commas to separate their names. In the policy list, right-click Set the Remote Desktop licensing mode , and then select Properties.

Follow this section's instructions carefully. Serious problems can occur if the registry is modified incorrectly. Before you starty modifying the registry, back up the registry so you can restore it in case something goes wrong.

To resolve this problem, back up and then remove the X Certificate registry keys, restart the computer, and then reactivate the RD Licensing server. Follow these steps. If you verify that the licensing configuration is correct, but the system still isn't correctly issuing CALs, follow these steps:.

The top window of the RD Licensing Diagnoser lists problems that the diagnoser has detected. For example, you might see a message that resembles the following:. The RD Licensing Diagnoser Information section shows more information about the problem, including its possible causes and the steps to follow to remediate it.

It has done this 2 time s. Then about 20 minutes later in the Event Viewer I see this error: "The terminal server could not locate a license server in the CompanyName. When I check Services, the service "Terminal Server Licensing" is set to Automatic, but the service is not started, and cannot be started. Error message that "Could not start the terminal server license server on local computer.

Error The process terminated unexpectedly. Hi, your best bet will be probably uninstalling the License Server and Installing it again. Call Microsoft Clearinghouse to tranfer you licenses to the new installation. You will also have to define the prefered License Server on the server as I understood the server has been both Terminal Server and License server at the same time before.

It tries to find a License Server since the one on himself isnt working anymore and tries to do that on a DC Enterprise Discovery.



0コメント

  • 1000 / 1000